Google將在下一版Android Q再次提高App API級別 避免用戶隱私遭不當使用

根據XDA Developers論壇指出,Google計畫在下一版Android (Android Q)版本提高App API級別判定限制,若使用者所執行的App API級別低於23以下,亦即僅針對Android 5.0以前版本設計的App,未來將無法正常在新版作業系統內運作。

其實在Android P (Android 9.0 Pie)等版本釋出時,Google就已經有針對僅以舊版Android打造的App內容做清理,最主要就是希望清除長時間未做更新的App,避免使用者安裝使用時,可能面臨惡意攻擊利用舊版漏洞竊取使用者資訊,或是造成App內容執行效率不佳,產生不良使用體驗。

類似的情況,其實也在蘋果iOS平台上出現,針對許久未做更新,或是版本未作升級的App內容,蘋果也會告知必須進行改善,否則將從App Store內剔除,同時在新版iOS作業系統環境也會出現無法相容運作情況。

另一方面,藉由App API級別限制,同時也能避免使用者持續使用舊版作業系統,而開發者所提交App內容也能在此政策下維持更新,避免有心人士透過舊版Android已知漏洞問題進行攻擊。

而從Google稍早向開發者發出通知顯示,從今年8月1日起提交預計在Google Play上架的App內容,其API級別至少要在26以上,亦即必須以Android 8.0執行環境打造,同時在今年11月之後,所有在Google Play上架的App內容也必須將App的API級別更新至26,藉此在新版Android獲得更高安全隱私,以及儲存與電力表現優化效益。

不過,將API級別提昇意味代表Google將在Android App內加上更嚴謹的使用權限監控,避免開發者隨意透過任何方式取得使用者裝置存取權限,因此對於部分App開發者而言,自然不會希望Google有過多監控機制介入,例如本身打造App主要便是藉由蒐集用戶所在位置進行使用,或是在App內透過其他付費繞過Google分潤機制,但Google持續將API級別提昇則是希望避免此類情況過於氾濫。

發表迴響